How do I update my Flash Player?

Solitaire Arena requires the most recent version of Adobe Flash Player to run properly. To check your current version and / or install the most recent version of place player, visit the following link: Flash Player

Was this article helpful?

2 out of 4 found this helpful

Have more questions? Submit a request

Comments

0 comments

Please sign in to leave a comment.